Iberia production issues
Incident Report for Duffel
Resolved
The production issues have been resolved.
Posted Jun 14, 2021 - 16:52 UTC
Investigating
Iberia has communicated that they are having production issues. Once we have more details we'll post an update.
Posted Jun 11, 2021 - 08:28 UTC
This incident affected: Airline Integrations (Live) (Iberia).