Duffel

Report a problemSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Intermittent card creation failures
Monitoring·Degraded performance

Card creation continues to operate normally following the mitigation. We have observed no further errors matching the incident since deployment and are continuing to monitor production traffic. The incident remains under

Mon, Sep 21, 2026, 03:27 PM
(7 hours ago)
·
Affected components
01:45 PM
Now
API - Card Payments (api.duffel.cards)
Updates

Monitoring

Card creation continues to operate normally following the mitigation. We have observed no further errors matching the incident since deployment and are continuing to monitor production traffic. The incident remains under

Mon, Sep 21, 2026, 03:27 PM

Monitoring

We observed intermittent failures affecting card creation between 13:06 and 13:50 BST. Card creation requests have been processing successfully since 13:50 BST, and we have not observed further errors.

We are continuing to monitor the service closely and are preparing improvements to reduce the impact should the issue recur.

Mon, Sep 21, 2026, 01:45 PM(1 hour earlier)

Investigating

We are investigating intermittent failures affecting card creation.

Most requests are succeeding, but a small number may return errors. Our systems are currently processing card requests successfully, and we are continuing to monitor for recurrence.

We’ll provide another update as soon as we have more information.

Mon, Sep 21, 2026, 01:08 PM(37 minutes earlier)