Monitoring
Latency has recovered to normal levels.
Investigating
United shopping and pricing requests are showing increased latency. This may result in missing content. We are in touch with supplier and will provide further updates as soon as we have more information.