Increased error rate on POST /air/orders
Resolved·Partial outage

This issue has been resolved.

Tue, Feb 24, 2026, 09:29 PM
(1 hour ago)
·
Affected components
Updates

Resolved

This issue has been resolved.

Tue, Feb 24, 2026, 09:29 PM

Identified

The issue with the supplier for some airlines (American, Aeromexico, WestJet) which caused errors when creating orders has reoccured. The supplier is aware of the issue and is rolling out a fix.

Tue, Feb 24, 2026, 08:59 PM(29 minutes earlier)

Resolved

Issue with American Airlines integration resolved, and we have re-enabled the AA integration

Tue, Feb 24, 2026, 05:03 PM(3 hours earlier)

Monitoring

We have been informed by the AA source that the connection was restarted. The 503 errors have subsided for now. Continuing to monitor.

Tue, Feb 24, 2026, 04:47 PM(16 minutes earlier)

Identified

The American Airlines issue is also affecting AA flights served by Travelport. Travelport have acknowledged this issue too.

Tue, Feb 24, 2026, 04:04 PM(42 minutes earlier)

Identified

American Airlines has acknowledged the issue, and is currently investigating it. We have disabled the AA integration for organisations that have another Duffel source for this content.

Tue, Feb 24, 2026, 03:08 PM(56 minutes earlier)

Investigating

We are still investigating the issue with our American Airlines integration.

We have reached out to them regarding the outage

Tue, Feb 24, 2026, 02:55 PM(12 minutes earlier)

Investigating

We are currently investigating an issue with our american airlines integration that's leading to an increased error rate on the POST /air/orders endpoint.

Tue, Feb 24, 2026, 02:32 PM(23 minutes earlier)