Duffel

Jetstar order creation unavailable
Resolved
Partial outage
Lasted for 6d

The payment error issue with Jetstar has been resolved, and we have successfully restored full functionality to Jetstar services. You can now book and make payments without any concerns. We apologize for any inconvenience caused and appreciate your patience.

Fri, May 26, 2023, 03:50 PM
4 months ago
Affected components
Updates

Resolved

The payment error issue with Jetstar has been resolved, and we have successfully restored full functionality to Jetstar services. You can now book and make payments without any concerns. We apologize for any inconvenience caused and appreciate your patience.

Fri, May 26, 2023, 03:50 PM
6d earlier...

Investigating

We are currently experiencing payment errors that prevent successful transactions with Jetstar. We have already reached out to Jetstar for support, and we are eagerly awaiting their assistance. It's important to note that BYO customers are not affected by this issue.

Fri, May 19, 2023, 04:52 PM