Resolved
Issue with Iberia integration resolved.
Investigating
We are currently investigating an issue with our Iberia NDC integration.
Investigating
We are currently investigating an issue with <integration name> integration.
Investigating
We are currently investigating an issue with our Iberia integration.