Resolved
Iberia order creation error rates have gone back to normal.
Monitoring
Iberia is reporting the outage has been resolved. We are continuing to monitor error rates.
Identified
We're observing high rates of order creation failures on the Iberia integratio.