Duffel

Report a problemSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Flight search is returning errors
Resolved·Degraded performance

The issue has been fixed.

Thu, Apr 16, 2026, 12:24 PM
(2 months ago)
·
Affected components
Apr 16, 2026, 12:11 PM
12:24 PM
Updates

Resolved

The issue has been fixed.

Thu, Apr 16, 2026, 12:24 PM

Identified

We are observing errors across all integrations and are working on a fix.

Thu, Apr 16, 2026, 12:11 PM(12 minutes earlier)