Issue with api.duffel.com integration has been resolved.
API and Dashboard requests are being handled as expected and error rates are back to expected levels.
Resolved
Issue with api.duffel.com integration has been resolved.
API and Dashboard requests are being handled as expected and error rates are back to expected levels.
Monitoring
Successful responses are being returned on api.duffel.com, we're currently monitoring error rates to confirm the issue has been resolved.
Investigating
We are currently investigating an issue with a high number of timeouts / errors being returned by api.duffel.com