·
Issue with <integration name> integration resolved.
Resolved
Investigating
We’re experiencing issues receiving chats through the travel Assistant. Please send any urgent requests to travel.assistant@duffel.com