·
Issue with <integration name> integration resolved.
Resolved
Identified
We are currently investigating errors on the on the Duffel dashboard search. We have identified an issue and are rolling out a fix.