British Airways order creation issues
Resolved
Partial outage
Lasted for 46m

Issue with British Airways integration resolved.

Wed, Feb 7, 2024, 02:32 PM
2 months ago
Affected components
Updates

Resolved

Issue with British Airways integration resolved.

Wed, Feb 7, 2024, 02:32 PM
46m earlier...

Investigating

We are currently investigating an issue with British Airways integration that is preventing orders from being created.

Wed, Feb 7, 2024, 01:45 PM